validate_integrity error when saving creatives
Incident Report for Xandr
Postmortem

INCIDENT SUMMARY From approximately 20:18 UTC on June 12, 2018, some creatives were unable to be updated & saved in the UI. A change to an unrelated model broken a UI-only data integrity check, causing certain PUT calls from the UI to fail with error: "with validateintegrity enabled you must pass lastmodified or last_activity value."

SCOPE OF IMPACT During the incident window, customers were unable to update & save creatives.

TIMELINE (IN UTC) 2018-06-12 04:28: Customer-reported consistent failure 2018-06-12 13:44: Escalated to Engineering team 2018-06-12 14:17: Config rolled back, resolving the issue

CAUSE ANALYSIS The incident was caused by a faulty route released to a UI routing application. The route was an exception required only by the legacy creative workflow.

RESOLUTION STEPS The release was rolled back to previous stable version once the issue was escalated to engineers.

NEXT STEPS Improve config release process specifically for legacy routes

Posted Jun 19, 2018 - 15:31 UTC

Resolved

The following incident has been fully resolved, and we will post a post-mortem as soon as we have completed one:

  • Component(s): Buy-side Console pages, User Segments, Creative Console pages
  • Impact(s):
    • Unable to save/edit objects
  • Severity: Minor Outage
  • Datacenter(s): LAX1, FRA1, NYM2, AMS1

We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Jun 12, 2018 - 14:34 UTC